Antara Owners Club banner
1 - 9 of 9 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Here's a new one.
1300miles on my new Antara se nav and its back into the dealers.
High engine cooling temp light came on, instant loss of power and aircon blowing hot air.
Just got a call from the dealer, the ecu that controls the engine cooling and aircon has packed in. new one on order.
Dealer has given me a Moka to run about in and if its a long wait for part vauxhall will give me a hire car.
Good responce from dealer but would rather have my Antara.
 

·
Premium Member
Joined
·
1,758 Posts
Decent response from the dealer and at least they seem to know what the fix is. hopefully it will be good as new for you asap.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #4 ·
Spare part to fix overheating will not be in uk till August. Got hire car from vauxhall now but tried to pull the £500 excess trick, NO WAY, dealer will cover the excess.
 

·
Registered
Joined
·
86 Posts
forresgo said:
Spare part to fix overheating will not be in uk till August. Got hire car from vauxhall now but tried to pull the £500 excess trick, NO WAY, dealer will cover the excess.
I think it's amazing how in this day an age that you can get just about anything from anywhere to anywhere else on the planet in 24 - 48 hours (fed ex etc) but if you want a part for a VX oh no will take weeks
 

·
Registered
Joined
·
324 Posts
forresgo said:
Spare part to fix overheating will not be in uk till August. Got hire car from vauxhall now but tried to pull the £500 excess trick, NO WAY, dealer will cover the excess.

Can you not get it from a Chevrolet dealer?
 

·
Registered
Joined
·
103 Posts
My antara seems to be getting too hot at minute but no warning light but cooling fan always on not doing regen and cant touch anything under or will burn hand even plastic air con not on anyone flses like this
 

·
Registered
Joined
·
3 Posts
Hi
I have the same problem on my 2012 Antara SE Nav Auto. The Engine Temp warning light comes on and then it goes into limp mode (10-20 mph) with no heat available from the heating system. So far the Vauxhall dealership have replaced the coolant temp sensor but it did not fix the problem and now they want another load of cash to continue with further diagnostics. Another respected garage have stated they have had numerous problems with other Antara models which have been rectified with changing thethermostat. Has anyone got any advice?
Regards Gareth
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top