Wiper Linkage Problem? - Vauxhall Antara Forums
 1Likes
  • 1 Post By Richy
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 10th January 2020, 13:42 Thread Starter
Junior Member
 
Join Date: Dec 2019
Posts: 28
Wiper Linkage Problem?

Wiper blades started playing up this morning, one blade works fine, the other one goes half way up then they both catch in the middle, haven't had a look yet - but are these known for linkage problems? Waiting to hear back from the garage as to when they can fit it in - but have ordered some linkage clips to be delivered tomorrow just in case it is them. Could even just need the wiper blade nut nipping down - will have a look in the morning.

Anyone had anything like this happen before?
geodark is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11th January 2020, 13:02
Senior Member
 
Join Date: Feb 2019
Location: Warwickshire
Posts: 123
Yep

Torrential rain in September on the M5, caravan in tow and the wiper linkage decided to come adrift. It was the passenger side but then jammed the mechanism and I lost the wipers all together. Really it couldn't of happened at a worst time. Very fortunately their was a service road which I managed to pull into off the M5, I removed the passenger wiper in the torrential rain which freed up the mechanism and I managed to get home.

When I stripped the mechanism down, this must of happened before because the seal on the failed linkage was damaged.
I ordered replacement linkages and arms, their is a kit on Ebay. You must throughly clean all surfaces (really important) then re-lube, I used silicone grease and clipped the new linkages back in place.

In my case it looks like this had been taken apart and had been contaminated with dirt and probably not re greased, as the dirt had eroded the nylon ball cup and it just popped off.

Its a pretty simple job, you need to remove the wipers and plastic bulkhead cover at the bottom of the windscreen then the whole wiper mechanism is accessible.

Richy
Richy is offline  
post #3 of 4 (permalink) Old 13th January 2020, 12:24 Thread Starter
Junior Member
 
Join Date: Dec 2019
Posts: 28
Started the job on sunday, all ready to do a full on how to video etc, took the cap off the wiper arm and... the nut was loose! repositioned the blade, nipped the nut down and all was well again Even bought in some of those universal linkage repair clips to tide me over until the new bits arrived! I have to say, I dont mind when issues are that easy to fix haha
geodark is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 15th January 2020, 07:12
Senior Member
 
Join Date: Feb 2019
Location: Warwickshire
Posts: 123
Excellent saved yourself some money as well. Richy
geodark likes this.
Richy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Vauxhall Antara Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome